问题来源Filebeats:

问题:启动Filebeats报如下错误:

No modules or prospectors enabled and configuration reloading disabled. What files do you want me to watch?

解决

是因为我的版本问题,我的版本是filebeat-6.2.2-linux-x86_64
在6.3版本以后,在配置文件中需要把filebeat.prospectors 修改为filebeat.inputs

版本6.2,修改后的配置文件为:

filebeat.prospectors:
- type: log
  enabled: true
  paths:
    - /root/programs/logstash-tutorial.log

output.logstash:
  hosts: ["localhost:5044"]	

Q.E.D.


只有创造,才是真正的享受,只有拚搏,才是充实的生活。